2018 Honda Accord Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So recently I've been driving and all of a sudden my car feels like I'm losing power. I give it gas and it moves nowhere, I have to release the gas and press again for it to move, it happens maybe once in awhile, I put it in sport mode, and I see when it happens, my turbo meter drops, all the way down. Then it goes up as I give gas, I have hondata tune in it, I have borla exhaust and k and n air filter, can it be my tune? I took it to the dealer and they said nothing is wrong, but I feel it when I drive, like I'm losing power to the engine. Its a 2.0t, it rained really bad out here and I thought maybe rain got into my air filter, but it hasn't rained in awhile, and it's still doing it. Its wierd as ****, has this happened to anyone? When it happens, no matter how much I press on the gas, it won't move, I have to press and depress.to drive normal.idkkkkk. the dealer did connection tests and a update to the ecu I guess and nothing, but when it rained, I saw a dead mouse by my intake and my filter was off. I hope that fkr didn't get in there and do damage. Just wierd why it haooens once in awhile. A mouse, lmao... at 1st I thought it clogged my filter. But it didn't. Car has like 15k miles,, and im regretting doing tunes and work to it now.. any ideas...thanks again.
 

·
Registered
2018 Accord Sport 2.0T 6MT
Joined
·
111 Posts
Fuel pump recall?
fuel pump is usually an "it works until it doesn't" kind of thing. something like that could be tune related. idk how the hondata works but some of the quick settings in ktuner gave me weird drop offs like that until i played around with them more. i had to change throttle responsiveness, throttle padding and turbo responsiveness to get everything where i wanted and eliminate something like what the OP is experiencing.
 

·
Registered
Joined
·
8 Posts
Your pedal assembly could be going bad. I would find a used one and change it out. Vey easy 3 nuts and the plug.
 

·
Registered
Joined
·
1 Posts
So recently I've been driving and all of a sudden my car feels like I'm losing power. I give it gas and it moves nowhere, I have to release the gas and press again for it to move, it happens maybe once in awhile, I put it in sport mode, and I see when it happens, my turbo meter drops, all the way down. Then it goes up as I give gas, I have hondata tune in it, I have borla exhaust and k and n air filter, can it be my tune? I took it to the dealer and they said nothing is wrong, but I feel it when I drive, like I'm losing power to the engine. Its a 2.0t, it rained really bad out here and I thought maybe rain got into my air filter, but it hasn't rained in awhile, and it's still doing it. Its wierd as ****, has this happened to anyone? When it happens, no matter how much I press on the gas, it won't move, I have to press and depress.to drive normal.idkkkkk. the dealer did connection tests and a update to the ecu I guess and nothing, but when it rained, I saw a dead mouse by my intake and my filter was off. I hope that fkr didn't get in there and do damage. Just wierd why it haooens once in awhile. A mouse, lmao... at 1st I thought it clogged my filter. But it didn't. Car has like 15k miles,, and im regretting doing tunes and work to it now.. any ideas...thanks again.
I know in our area we had a ton of pollen. Now that we are coming out of that season, changing an air filter or cleaning the cone on a cold air could benefit. Just a thought.
 
1 - 7 of 7 Posts
Top