2018 Honda Accord Forum banner
1 - 5 of 5 Posts

·
Registered
2019 Honda Accord 2.0T
Joined
·
209 Posts
Discussion Starter · #1 · (Edited)
Well guys been a minute since I posted. I was driving yesterday back home from Jury Duty and caught a red light at a busy intersection. Nothing seemed weird but once I came to a complete stop 30 seconds later the car freaked out and displayed errors and a check engine light came on and the vehicle shut off and put itself in Park. The dash was displaying messages like if I had just uploaded a tune for reference. I tried multiple times to start the car but nothing, not even a crank. Officer pulled up behind us and re directed traffic to the next lane over while we waited for a tow, I aired the car up so it wouldn’t scrape. Tow truck pulled up which was painful to watch the car get towed in Park and the process of bringing the car down off of it was just as bad. Got it dropped off to the nearest Honda Dealer which was 3 minutes away. Honda advisor told me he would give me a call in an hour and see what’s going on. I get a call an hour later and was told that they are having trouble getting info from the obd2 but they can try another way of getting the info tomorrow morning. This morning came, I get a call from the SA and told me that they are still having trouble getting any communication with the ecm. I brought my Ktuner to see if I can pull up any codes and still nothing. The tech asked me if I had flashed the car recently told him I did back in January but the car has been fine. They believe it to be the ECU and will be quoted later on today for a new one and programming it. The sucky part about this whole experience is that I will need to buy a new license for the ktuner so I can lock it to the new ECU $200 quoted from Ktuner already just need to send it out. New ECU $xxxx and ̶r̶e̶t̶u̶n̶i̶n̶g̶ ̶i̶t̶ ̶o̶n̶ ̶t̶h̶e̶ ̶d̶y̶n̶o̶ ̶$̶6̶5̶0̶. I will post when I have an update and hopefully have the car up and running. Has anyone encountered this at all?
Edit: ECU $414
Wheel Tire Car Land vehicle Sky
 

·
Registered
Joined
·
40 Posts
Damn that blows! I have not heard of this ever occurring. Did you try maybe disconnecting the ECU and reconnecting? That seems like a long shot but at this point anything helps. Sounds like hardware randomly decided to fail since you flashed back in January theres no way to blame it on the tune really.

As for retuning on the dyno, your tuner should have done a good job at saving your tune revisions after finishing up at the dyno and provided them to you for safe keeping. Then it would just be a matter getting your new KTuner license and uploading the calibration file.
 

·
Registered
2019 Honda Accord 2.0T
Joined
·
209 Posts
Discussion Starter · #3 · (Edited)
̶I̶ ̶h̶a̶v̶e̶ ̶m̶y̶ ̶t̶u̶n̶e̶s̶ ̶s̶a̶v̶e̶d̶ ̶b̶u̶t̶ ̶I̶ ̶b̶e̶l̶i̶e̶v̶e̶ ̶t̶h̶e̶ ̶p̶r̶o̶b̶l̶e̶m̶ ̶i̶s̶ ̶t̶h̶a̶t̶ ̶I̶ ̶c̶a̶n̶’̶t̶ ̶u̶p̶l̶o̶a̶d̶ ̶t̶h̶e̶m̶ ̶o̶n̶ ̶t̶h̶e̶ ̶n̶e̶w̶ ̶e̶c̶u̶ ̶s̶i̶n̶c̶e̶ ̶i̶t̶’̶s̶ ̶n̶o̶t̶ ̶g̶o̶i̶n̶g̶ ̶t̶o̶ ̶b̶e̶ ̶t̶h̶e̶ ̶s̶a̶m̶e̶ ̶l̶i̶c̶e̶n̶s̶i̶n̶g̶ ̶a̶n̶d̶ ̶e̶c̶u̶ ̶p̶a̶r̶t̶ ̶n̶u̶m̶b̶e̶r̶ ̶t̶h̶a̶t̶ ̶t̶h̶e̶ ̶t̶u̶n̶e̶ ̶i̶s̶ ̶a̶s̶s̶i̶g̶n̶e̶d̶ ̶t̶o̶. I will give Drob a email and find out. If it works then great if not then I just have to roll with the punches.
As far as disconnecting the ecu I haven’t tried that yet.

Edit: Ktuner and Drob got back to me, My custom etune will work on the new ecu aslong as the new ecu numbers end the same it should work.
 

·
Registered
2019 Honda Accord 2.0T
Joined
·
209 Posts
Discussion Starter · #5 ·
Update #1
Just got off the phone with the tech. They are going to replace the ecu with a brand new one and program it. Unfortunately the part can’t be ordered until Monday morning. I informed them that the car won’t be able to turn on with the factory tune because of the 4bar map sensors so I’ll be dropping off the stock ones the day of install for them to swap out and to expect the idiot light to be on due to the other modifications I have done that need the codes disabled via ktuner. I’m shipping the ktuner Monday, hoping to have it back asap. I most likely won’t drive the car back home on factory tune so until the ktuner comes back it’s just going to sit.

Edit: Car won’t be sitting at dealer, scheduling up a tow after everything comes back good with the install hopefully this time it will be towed in Neutral.
 
1 - 5 of 5 Posts
Top