2018 Honda Accord Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I’ve owned my Honda for about 2.5 years and have had zero issues with the infotainment center screen before now. Drove it to Walmart yesterday for Christmas shopping, screen and everything worked great. Got back in the car and fired her up, screen gets a little brighter but never displays anything at all, see attached photo. The screen is still functional, as it does switch to my backup camera when I go in reverse, however the touchscreen UI to switch between different POVs doesn’t show up at all. I cannot manipulate any of the features or functions at all because the screen stays light up but displaying nothing. Both my USB ports also stopped charging my phone as well. I tried just turning the car on and off and I have also tried holding the audio power button to “reboot” the system, but it doesn’t seem to do anything at all. Has anyone experienced this before and if so, what was the fix?
Plant Automotive design Gadget Audio equipment Personal luxury car

Plant Vehicle Satellite radio Personal luxury car Vehicle audio
 

· Registered
Joined
·
55 Posts
Grabbed this from another forum, give this a shot. It’s fixed my issue before, it resets the head unit.

1. Step on Brake
2. Start engine, then immediately shift on reverse by pressing Reverse button. This will turn on the reverse camera.
3. After 2 to 4 sec, shift to neutral (press Neutral button). At this point, the head unit will restart. The delayed availability of "OK" button (greyed out) on the disclaimer screen indicates that the head unit is indeed restarting. If The "OK" on the Head unit is immediately available after shifting to Neutral, the process did not work, repeat the process.
4. Recheck the "Up time" and it should only be a few seconds at that point. Head unit has been successfully restarted.
 
1 - 3 of 3 Posts
Top