2018 Honda Accord Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all. New around here. I've been looking for help with my ride. I've a 2018 Accord 1.5t. It has 75k and a few basic mods. Ktuner, catch can and intake.
My issue is when I'm driving highway speeds, 60-80 at 2300 RPMs and lite pressure on the gas everything is fine. When I let of the gas the RPMs gradually rise. They have gone as high as 3k! The engine doesn't rev and the MPG tracker stays normal. When I push on the gas again it jumps back to normal RPMs with a little bump in the engine. Today it did the same thing but at very low speeds and there was a loud humming noise the slower I went... 10-20 MPH. I'm really concerned now but can't find any help.
Thank you all for your time!
 

·
Super Moderator
Joined
·
1,665 Posts
Have you tried contacting KTuner to see if they could help?
 

·
Registered
Joined
·
1 Posts
Hi all. New around here. I've been looking for help with my ride. I've a 2018 Accord 1.5t. It has 75k and a few basic mods. Ktuner, catch can and intake.
My issue is when I'm driving highway speeds, 60-80 at 2300 RPMs and lite pressure on the gas everything is fine. When I let of the gas the RPMs gradually rise. They have gone as high as 3k! The engine doesn't rev and the MPG tracker stays normal. When I push on the gas again it jumps back to normal RPMs with a little bump in the engine. Today it did the same thing but at very low speeds and there was a loud humming noise the slower I went... 10-20 MPH. I'm really concerned now but can't find any help.
Thank you all for your time!
Make sure you use 91 or higher octane on ktuner or you will have issues as described. See if that changes things
 

·
Super Moderator
Joined
·
1,665 Posts

·
Super Moderator
Joined
·
1,665 Posts

·
Super Moderator
Joined
·
1,665 Posts
1 - 9 of 9 Posts
Top